Password Retention Manager supported versions

Published by Admin on

As of 02.01.2020 older versions of the Password Retention Manager are no longer supported. Development and support will only focus on the following versions:

2.6.2.44
2.6.2.46 (hot fix)
2.6.2.56 (Hot fix)

Thank you for your feedback over the past months! We’re working on something really big right now… Details will follow in Q3 2020!

Categories: All

0 Comments

Leave a Reply

Your email address will not be published. Required fields are marked *